I no longer support Internet Explorer lower than version 9.
You can only view this site in IE if you install the Chrome Frame. However, I recommend the browsers above which you can download by clicking.